Whole Tomato Software Forums
Whole Tomato Software Forums
Main Site | Profile | Register | Active Topics | Members | Search | FAQ
 All Forums
 Visual Assist
 Technical Support
 Snippet editor colors not dark...

You must be registered to post a reply.
Click here to register.

Screensize:
UserName:
Password:
Format: BoldItalicizeUnderlineStrikethrough Align leftCenterAlign right Insert horizontal ruleUpload and insert imageInsert hyperlinkInsert email addressInsert codeInsert quoted textInsert listInsert Emoji
   
Message:

Forum code is on.
Html is off.

 
Check to subscribe to this topic.
   

T O P I C    R E V I E W
jwiede Posted - Dec 11 2014 : 11:08:48 PM
VAX 2052, VS2013 sp4, Win8.1x64

When in "light" color theme setting for VS2013, the VAX snippets editor looks fine. However, switch VS2013 to "dark" color theme, and most of the VA Snippet Editor dialog colors used remain the same. Dialog using light colors while VS2013 is using dark colors results in illegible text/gadget combinations, making editing/viewing dialog contents difficult to impossible.

Probably unrelated, but I notice Windows std "info" noise (kind of "boink!" by default) sounds every time I open the Snippet Editor dialog as well.

If there's a workaround to get colors fixed in Snippet Editor dialog with VS2013 in dark theme, I'd love to know it!

Thanks!
6   L A T E S T    R E P L I E S    (Newest First)
jwiede Posted - May 10 2016 : 3:55:03 PM
That's great, thanks Sean!
sean Posted - May 10 2016 : 3:48:57 PM
case=87033 is implemented in build 2097
feline Posted - Dec 19 2014 : 11:19:03 PM
I am not sure what happened there, but thank you for the update, it is good to know that the partly coloured problem has been fixed.

I have put in a feature request to theme the VA Snippet editor dialog, since as you say it does stand out that it is not yet themed:

case=87033

The template source code, it is all clear to me in a dark theme, and it looks clear in your screen shots. With the part dark dialog, the editor background is still white and the snippet code is showing clearly. Are you getting this problem with specific snippet code?
jwiede Posted - Dec 15 2014 : 2:37:39 PM
quote:
Originally posted by sean

I see an extra icon in the title bar. Is that a 3rd party utility?


Yes, a widget from "Display Fusion", but uninstalling Display Fusion, rebooting, and firing up VS13+VAX didn't make a difference. On a hunch, though, I then uninstalled and reinstalled the VA extensions (after re-installing Display Fusion), rebooted, and launched VS13+VAX and the problem was gone. No clue what caused the problem, but uninstall-reinstall of the extensions appears to be a workaround (at least) if it happens again.

Any ETA on when such dialogs will be themed appropriately? The template source display can be a bit difficult to read with its coloration. Failing that, any way to change the dialog's colors to use light-on-dark for its source code display?

Thanks!
sean Posted - Dec 12 2014 : 7:28:11 PM
Given the boink and the odd colors, my hunch is an exception in the dialog init. The dialog is not supposed to be VS themed - and it is not what I see.

Here's what the editor looks like in my 8.1 environment with VS2013 dark theme:



I see an extra icon in the title bar. Is that a 3rd party utility?
jwiede Posted - Dec 12 2014 : 6:28:53 PM
Here's a picture of the dialog color scheme problem:



Any help, workarounds, or even confirmation would be welcome.


© 2021 Whole Tomato Software, LLC Go To Top Of Page
Snitz Forums 2000