Whole Tomato Software Forums
Whole Tomato Software Forums
Main Site | Profile | Register | Active Topics | Members | Search | FAQ
User name:
Password:
Save Password
Forgot your password?

 All Forums
 Visual Assist
 Technical Support
 Surround Selection not working on VS2019
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

Alkerion
New Member

7 Posts

Posted - Aug 22 2019 :  6:59:01 PM  Show Profile  Reply with Quote
HI !

I've finally moved from VS2017 to the latest VS2019 with the latest VA an I can't get the "Surround Selection" to work.

When I select several lines and press / or * the lines are deleted.

VS 16.2.3
VA_X.dll file version 10.9.2341.2 built 2019.08.05
DevEnv.exe version 16.2.29215.179 Community
msenv.dll version 16.0.29215.179
Comctl32.dll version 6.10.18362.295
Windows 10 10.0 1903 Build 18362.295

Any help appreciated

Regards

accord
Whole Tomato Software

United Kingdom
3212 Posts

Posted - Aug 23 2019 :  04:53:07 AM  Show Profile  Reply with Quote
- Are you using C++ or C# or something else?
- Do you have the following settings ticked?
VA Options -> Editor -> Surround selection via character toggles
VA Options -> Editor -> /
VA Options -> Editor -> *

Edited by - accord on Aug 23 2019 04:53:31 AM
Go to Top of Page

Alkerion
New Member

7 Posts

Posted - Aug 23 2019 :  05:12:30 AM  Show Profile  Reply with Quote
Yes it's for C++.

I've the settings ticked.

Already tried to untick/tick, restart, install again....

It was working great on VS2017.
Go to Top of Page

accord
Whole Tomato Software

United Kingdom
3212 Posts

Posted - Aug 23 2019 :  05:49:43 AM  Show Profile  Reply with Quote
Do other functions work? For example, can you run VA Find References on a symbol?

Can you please do an enable/disable cycle?

1. Disable VA through extension manager: Extensions -> Manage Extensions...
2. Find VA
3. Click Disable
4. Restart Visual Studio
5. Enable VA through extension manager: Extensions -> Manage Extensions...
6. Restart Visual Studio

Does this make any difference?
Go to Top of Page

accord
Whole Tomato Software

United Kingdom
3212 Posts

Posted - Aug 23 2019 :  05:54:53 AM  Show Profile  Reply with Quote
Also, very important question: did Visual Assist integrate into your Visual Studio editor?
To answer this question, you need to check if you can see VA Navigation Bar on the top of the editor:
https://docs.wholetomato.com/default.asp?W188
Go to Top of Page

Alkerion
New Member

7 Posts

Posted - Aug 23 2019 :  6:33:22 PM  Show Profile  Reply with Quote
Hi !

I finally found the issue.

VA is not working with Arduino project anymore with VS2019 as it was with VS2017.

I followed this tutorial and now it works as expected :
https://docs.wholetomato.com/default.asp?W328

Added .ino to ExtSource

Edited by - Alkerion on Aug 23 2019 7:18:57 PM
Go to Top of Page

accord
Whole Tomato Software

United Kingdom
3212 Posts

Posted - Aug 24 2019 :  12:21:07 PM  Show Profile  Reply with Quote
*oh* you are using C++ but with a non-standard extension. Makes sense now
I'm glad it works now!
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
© 2019 Whole Tomato Software, LLC Go To Top Of Page
Snitz Forums 2000