Whole Tomato Software Forums
Whole Tomato Software Forums
Main Site | Profile | Register | Active Topics | Members | Search | FAQ
User name:
Password:
Save Password
Forgot your password?

 All Forums
 Visual Assist
 Technical Support
 Newlines added when using enclose snippet
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

Miclar
New Member

Denmark
3 Posts

Posted - Apr 19 2017 :  06:21:41 AM  Show Profile  Reply with Quote
How can I avoid unwanted newlines when enclosing selection in braces?

This:

core::vector3df mePos = itsWorld->itsPlayer->GetPos();
float meDir = itsWorld->itsPlayer->GetDir();
core::vectorSIMDf meDirection = itsWorld->itsPlayer->GetDirection();


Becomes:

	{
		core::vector3df mePos = itsWorld->itsPlayer->GetPos();
		float meDir = itsWorld->itsPlayer->GetDir();

		core::vectorSIMDf meDirection = itsWorld->itsPlayer->GetDirection();

	}

Miclar
New Member

Denmark
3 Posts

Posted - Apr 19 2017 :  11:41:32 AM  Show Profile  Reply with Quote
Bump.

Anyone?
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
14608 Posts

Posted - Apr 19 2017 :  1:44:52 PM  Show Profile  Reply with Quote
Which programming language are you using? I am guessing C++.

How are you selecting the text? Are you selecting full lines, including the EOL, or are you only selecting 2 EOL for 3 lines of text?

Can you look and see if you have:

IDE tools menu -> Options -> Environment -> Documents -> Check for consistent line endings on load

turned On or Off. If this is turned Off, can you please try turning this On, and then reload the file where you are seeing this problem. Do you get any messages from the IDE about mixed line types?

As for the bump, sometimes it takes us a day or two to get to new questions and bug reports. We try to respond fairly quickly, but sometimes you do have to be patient.

zen is the art of being at one with the two'ness
Go to Top of Page

Miclar
New Member

Denmark
3 Posts

Posted - Apr 19 2017 :  2:37:58 PM  Show Profile  Reply with Quote
quote:
Originally posted by feline

Which programming language are you using? I am guessing C++.


Yes, it is C++.

quote:

How are you selecting the text? Are you selecting full lines, including the EOL, or are you only selecting 2 EOL for 3 lines of text?


Yes, I was selecting full lines, i.e. 3 lines of text for the small example.

quote:

Can you look and see if you have:

IDE tools menu -> Options -> Environment -> Documents -> Check for consistent line endings on load

turned On or Off. If this is turned Off, can you please try turning this On, and then reload the file where you are seeing this problem. Do you get any messages from the IDE about mixed line types?


It was turned off, as you suspected, for reasons I don't understand. I know we have forced earlier but it was before we changed from VS2015 to VS2017.
Anyway I toggled it and reloaded, and it certainly removed the problem.
Thanks a lot.

quote:

As for the bump, sometimes it takes us a day or two to get to new questions and bug reports. We try to respond fairly quickly, but sometimes you do have to be patient.


Sure. I am new in this forum as you can see, and I wasn't sure if it is a staff handled forum or if I had to be lucky to get some help from another forum user.
If I know, that all posts are read answered in due time, I am very patient :)
In Some forums you are answered in 20-30 mins or not at all, that the reason for the bumb, just to make the topic visible.
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
14608 Posts

Posted - Apr 20 2017 :  10:14:35 AM  Show Profile  Reply with Quote
That's fair. You never know quite what to expect when moving to a new forum, so it is a fair question, and one that deserved an answer.

The mixed line endings setting comes up whenever something "odd" or "random" is happening with line spacing in a file. It is rare, but it does happen. It is more common if you are working across Windows and Mac or Linux, so maybe copying text from another file with a different line ending pattern, or even editing with a different setting.

Hopefully keeping this setting turned on will fix this problem for you, once all of the effected files have been opened and converted to a single type of line ending.

zen is the art of being at one with the two'ness
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
© 2017 Whole Tomato Software, Inc Go To Top Of Page
Snitz Forums 2000