Whole Tomato Software Forums
Whole Tomato Software Forums
Main Site | Profile | Register | Active Topics | Members | Search | FAQ
User name:
Password:
Save Password
Forgot your password?

 All Forums
 SourceLinks
 General
 Copy text to google doc with syntax higllighting
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

rowkajjh
Junior Member

15 Posts

Posted - Jul 01 2016 :  05:43:01 AM  Show Profile  Reply with Quote
Hi,

to get some code snippets from VS to a google document and have to copy it to MS Word before and copy it from here:
copy from VS -> paste MS Word -> copy from MS Word -> paste to Google doc

Otherwise I loose the syntax highlighting.
Is there a direct solution
copy from VS -> paste to Google doc

Thanks!

Edited by - rowkajjh on Jul 01 2016 06:10:54 AM

feline
Whole Tomato Software

United Kingdom
14761 Posts

Posted - Jul 01 2016 :  1:13:51 PM  Show Profile  Reply with Quote
Which IDE and browser are you using? If the syntax highlighting is appearing in MS Word, I am not sure why it is not appearing in Google doc when you copy and paste directly.

zen is the art of being at one with the two'ness
Go to Top of Page

rowkajjh
Junior Member

15 Posts

Posted - Jul 06 2016 :  07:17:47 AM  Show Profile  Reply with Quote
I use VS2013 und google chrome 51.0.2704.103 m.
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
14761 Posts

Posted - Jul 07 2016 :  2:24:06 PM  Show Profile  Reply with Quote
I am seeing the same effect here, and I have done some more tests, and have some interesting results.

This happens even without having VA or SourceLinks installed, which is what I would expect, since neither of these effect the clipboard content in VS2013.

When using the same google drive document in Internet Explorer 11 under Windows 7, paste keeps the formatting. So what ever is removing the formatting when doing a copy / paste from VS2013, it is related to Chrome, or google docs inside Chrome.

I don't have Word installed on this machine to test with, so I have tried WordPad instead. The formatting is preserved when pasting into WordPad, but interesting, when I copy from WordPad and paste into Chrome, the formatting is again lost. If I paste from WordPad into IE then the formatting is preserved.

We are considering a change to VA, to allow VA's coloring to be copied to the clipboard, currently you only get the IDE coloring in the clipboard. But given these results, I don't know if that would actually help or not.

I think I have found a work around. I have installed the "Productivity Power Tools 2013" extension, and then in:

IDE Tools menu -> Options -> Productivity Power Tools

I have made sure that HTML Copy is turned On. This is allowing formatting to be copied into Chrome directly for me.

zen is the art of being at one with the two'ness
Go to Top of Page

rowkajjh
Junior Member

15 Posts

Posted - Jul 08 2016 :  06:55:31 AM  Show Profile  Reply with Quote
PowerTools worked for me. Thanks!
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
© 2017 Whole Tomato Software, Inc Go To Top Of Page
Snitz Forums 2000