Whole Tomato Software Forums
Whole Tomato Software Forums
Main Site | Profile | Register | Active Topics | Members | Search | FAQ
User name:
Password:
Save Password
Forgot your password?

 All Forums
 Visual Assist
 Feature Requests
 Double-buffering for VA Outline
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

calon
New Member

USA
5 Posts

Posted - Aug 06 2019 :  12:04:58 PM  Show Profile  Reply with Quote
Placing the cursor at various points in a document causes the VA Outline window to flicker every time it updates, even when the only visual change is that one entry becomes bold and another is no longer bold.

Any chance that window could get some double-buffering? Or something equivalent to that?

feline
Whole Tomato Software

United Kingdom
16050 Posts

Posted - Aug 07 2019 :  07:12:27 AM  Show Profile  Reply with Quote
Which IDE and version of VA are you using?

How are you moving the caret in the file?

If you right click inside VA Outline do you have "Auto Expand Nodes" turned On or Off?

So far, checking on two different machines here, I am not seeing anything I would call a flicker. There is a slight "something" where the bold item is being moved, but if I focus on other parts of VA Outline then I am not seeing any sign of a flicker or redraw. I am testing with Auto Expand turned Off and VA syntax colouring in VA Outline turned On.

zen is the art of being at one with the two'ness
Go to Top of Page

calon
New Member

USA
5 Posts

Posted - Aug 07 2019 :  11:40:11 AM  Show Profile  Reply with Quote
>Which IDE and version of VA are you using?

Microsoft Visual Studio Professional 2017
Version 15.9.13
VisualStudio.15.Release/15.9.13+28307.718
Microsoft .NET Framework
Version 4.7.03190

Visual Assist 10.9.2333.0

>How are you moving the caret in the file?

Various methods:

- Scrolling/clicking with the mouse
- Page Up/Down
- Arrow keys
- Selecting a item via Alt+M (List methods in current file)

>If you right click inside VA Outline do you have "Auto Expand Nodes" turned On or Off?

I have it turned *on*. With auto-expand off, the flickering is limited to when the VA Outline window needs to scroll something into view (e.g. Page Up/Down).

My ill-informed speculation: perhaps scrolling the window/control causes a redraw which, for whatever unknown reason, intermittently causes the window/control to go blank before properly redrawing.

Side-note: I think the active item needs more than just bold to call it out.
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
© 2019 Whole Tomato Software, LLC Go To Top Of Page
Snitz Forums 2000