Whole Tomato Software Forums
Whole Tomato Software Forums
Main Site | Profile | Register | Active Topics | Members | Search | FAQ
User name:
Password:
Save Password
Forgot your password?

 All Forums
 Visual Assist
 Technical Support
 VS.NET 2003 crash on exit
 New Topic  Topic Locked
 Printer Friendly
Author Previous Topic Topic Next Topic  

evolution
Ketchup Master

USA
87 Posts

Posted - Dec 12 2005 :  2:10:16 PM  Show Profile
I've getting a crash on exit whenever I close VS.NET 2003 if I have opened a solution (i.e. no crash if I just start VS.NET then shut it down). This began when I upgraded from build 1418 to 1432, but is still occurring in build 1437. By process of elimination, VAX seems to be the culprit. I uninstalled Incredibuild and VAX (the only two plug-ins I have installed), then reinstalled VS.NET 2003. Before installing any plug-ins, I tried opening my solution and then closing VS.NET - no crash. I installed the latest version of VAX (1437), opened the solution and closed VS.NET - same crash. It hasn't been that pressing of an issue, but since this causes any changes to e.g. toolbar locations to not be saved, it's starting to become inconvenient.
What other information can I provide that might be helpful in tracking this down?


VA_X.dll file version 10.2.1437.0 built 2005.12.10
Licensed to:
VA X: jeff@epicgames.com (1-user license) Support ends 2006.11.21
VA.NET 7.1:
VAOpsWin.dll version 1.3.3.0
VATE.dll version 1.0.4.2
DevEnv.exe version 7.10.3077.0
msenv.dll version 2.0.2417.0
Font: Courier New 13(Pixels)
Comctl32.dll version 5.82.2900.2180
WindowsNT 5.1 Build 2600 Service Pack 2
2 processors

Platform: Win32
Stable Includes:
c:\\Program Files\\Microsoft Visual Studio .NET 2003\\Vc7\\include;
c:\\Program Files\\Microsoft Visual Studio .NET 2003\\Vc7\\atlmfc\\include;
c:\\Program Files\\Microsoft Visual Studio .NET 2003\\Vc7\\PlatformSDK\\include\\prerelease;
c:\\Program Files\\Microsoft Visual Studio .NET 2003\\Vc7\\PlatformSDK\\include;
c:\\Program Files\\Microsoft Visual Studio .NET 2003\\SDK\\v1.1\\include;

Library Includes:
c:\\Program Files\\Microsoft Visual Studio .NET 2003\\Vc7\\atlmfc\\src\\mfc;
c:\\Program Files\\Microsoft Visual Studio .NET 2003\\Vc7\\atlmfc\\src\\atl;
c:\\Program Files\\Microsoft Visual Studio .NET 2003\\Vc7\\crt\\src;

Other Includes:


what could possibly go wrong? :D

support
Whole Tomato Software

5566 Posts

Posted - Dec 12 2005 :  2:28:03 PM  Show Profile
Do you have devenv.exe.manifest in the directory containing devenv.exe? If so, remove it.

Does the problem occur with a new, test solution you create?

Can you read the following thread to see if any of the problematic add-ins ring a bell?

http://forum.wholetomato.com/forum/topic.asp?TOPIC_ID=1383&SearchTerms=crash,exit
Go to Top of Page

evolution
Ketchup Master

USA
87 Posts

Posted - Dec 12 2005 :  2:44:37 PM  Show Profile
There was a devenv.exe.manifest.bak, but not a devenv.exe.manifest. I deleted it anyway (had no effect on the crash).

I created a new, test solution. I didn't get the crash on exit the first time I closed VS after creating the test solution, but when I restart VS, then open the test solution I just created, I get the same crash again.

None of those add-ins are installed on my machine that I know of. There are only three add-ins listed in the "Add in manager"'s list - Incredibuild, Test Track Pro, and VAX. Only Incredibuild and VAX are enabled (though I can't be sure that the add-in isn't doing something even though it's disabled, I guess). However, after reinstalling VS.NET 2003, VAX was the first and only add-in that I had installed (i.e. I tested before reinstalling the other add-ins) and I was getting the crash there as well. Can an add-in be installed yet not be listed in the Add-in manager's list?

what could possibly go wrong? :D
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
15905 Posts

Posted - Dec 12 2005 :  6:17:22 PM  Show Profile
i am not sure about an invisible addin myself, but i suppose it is possible, considering that this is not a clean OS. what anti-virus program are you running? i am wondering if this could be a factor, if it is somehow locking or hiding some of VA's files. it is a bit of a long shot, but i have seen anti-virus cause problems before.

have you done a spyware scan of your machine?

beyond this, are you able to get a call stack of the crashing IDE? also can you get a VA log file by loading the IDE with a test solution, turning on logging and then closing the IDE.

http://www.wholetomato.com/support/faq.html#log

zen is the art of being at one with the two'ness
Go to Top of Page

evolution
Ketchup Master

USA
87 Posts

Posted - Dec 13 2005 :  12:48:46 AM  Show Profile
Antivirus: Symantec
Antispyware: Spy Sweeper

Both of these are pushed to my machine via active directory, and have been installed for around 2 years (happily co-existing with VAX, mind you ;)).

I've sent along a zip to support containing the va.log, vassist.log, and callstack (which isn't very helpful without symbols) that indicates that the AV is in VSProjectEngine.dll.

what could possibly go wrong? :D
Go to Top of Page

sean
Whole Tomato Software

USA
2615 Posts

Posted - Dec 13 2005 :  9:48:41 PM  Show Profile
case=926 - crash at VS shutdown when xbox xdk is installed

This will be fixed in the next general release.
Go to Top of Page

support
Whole Tomato Software

5566 Posts

Posted - Dec 17 2005 :  11:58:36 AM  Show Profile
Fixed in 1438.
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Topic Locked
 Printer Friendly
Jump To:
© 2019 Whole Tomato Software, LLC Go To Top Of Page
Snitz Forums 2000