Whole Tomato Software Forums
Whole Tomato Software Forums
Main Site | Profile | Register | Active Topics | Members | Search | FAQ
User name:
Password:
Save Password
Forgot your password?

 All Forums
 Visual Assist
 Technical Support
 Lost "V" key in insert AutoText dialog
 New Topic  Topic Locked
 Printer Friendly
Author Previous Topic Topic Next Topic  

pfreese
Junior Member

USA
13 Posts

Posted - Dec 02 2005 :  2:57:59 PM  Show Profile
I just upgraded to build 1434 and am trying out the AutoText dialogs. For some strange reason, I cannot type an uppercase "V" in the dialog for AutoText templates which require input. Lowercase "v" works mostly, but occasionally seems to get trapped as well. If I fiddle with the dialog long enough, I can occasionally get it to accept the uppercase "V". Very strange.

License and config info:

VA_X.dll file version 10.2.1434.0 built 2005.11.25
Licensed to:
VA X: jasonr@secretlairstudios.com (2-user license) Support ends 2006.10.07
VA.NET 7.1:
VAOpsWin.dll version 1.3.3.0
VATE.dll version 1.0.4.2
DevEnv.exe version 7.10.3077.0
msenv.dll version 7.10.3077.0
Font: Courier New 13(Pixels)
Comctl32.dll version 5.82.2900.2180
WindowsNT 5.1 Build 2600 Service Pack 2
2 processors

Platform: Win32
Stable Includes:
C:\\Program Files\\Microsoft DirectX 9.0 SDK (June 2005)\\Include;
C:\\Program Files\\Microsoft Visual Studio .NET 2003\\Vc7\\include;
C:\\Program Files\\Microsoft Visual Studio .NET 2003\\Vc7\\atlmfc\\include;
C:\\Program Files\\Microsoft Visual Studio .NET 2003\\Vc7\\PlatformSDK\\include\\prerelease;
C:\\Program Files\\Microsoft Visual Studio .NET 2003\\Vc7\\PlatformSDK\\include;
C:\\Program Files\\Microsoft Visual Studio .NET 2003\\SDK\\v1.1\\include;

Library Includes:
C:\\Program Files\\Microsoft Visual Studio .NET 2003\\Vc7\\atlmfc\\src\\mfc;
C:\\Program Files\\Microsoft Visual Studio .NET 2003\\Vc7\\atlmfc\\src\\atl;
C:\\Program Files\\Microsoft Visual Studio .NET 2003\\Vc7\\crt\\src;

Other Includes:

feline
Whole Tomato Software

United Kingdom
16405 Posts

Posted - Dec 04 2005 :  5:42:14 PM  Show Profile
very odd. which field in the autotext dialog is this happening on? also which language are you creating / editing a rule for?

i have just tried this using VS 2003 and VA 1434 and i can type both lower and upper case v in the title, shortcut, description and code windows for a new C++ autotext item.

do you have any problems with v or V in the main code editor? how about notepad? have you tried restarting the IDE or the workstation? i am wondering if some strange windows accessibility mode got turned on briefly, but off hand i cannot think of one that would cause this problem.

any other plugin's installed? any keyboard shortcut programs running that might be trapping v under some conditions?

zen is the art of being at one with the two'ness
Go to Top of Page

evolution
Ketchup Master

USA
87 Posts

Posted - Dec 08 2005 :  9:44:29 PM  Show Profile
I have a similar problem (1434, VS.NET 2003). If I invoke AutoText that takes parameters (which brings up the dialog with controls for entering the values of those parameters), typing v will sometimes bring up the VAX special fancy paste menu. I have to press [and release] Ctrl or Shift to be able to type a v. Now when I say "Ctrl or Shift", I don't mean that it doesn't matter which one I press - the required button actually changes! Sometimes I have to press the Ctrl key to be able to type the V, sometimes it's the Shift key. It's behaving like Ctrl and Shift are toggle buttons, and both have to be toggled "on" for the bug to manifest.

See if you can reproduce it using these steps (this is in C++):

1. type 'forr' to invoke the autotext suggestion list
2. choose forward iteration loop
3. In either entry field (index or length), type v
4. If a v appears, press&release left-Shift, then type v
5. If a v appears, press&release left-ctrl, then type v
6. If a v appears, press&release left-shift again, type v

Using those steps I get the bug 100% of the time - the VAX paste menu will appear at any step between 3 and 6, depending on (I guess) what the "toggle" state is of the shift & ctrl buttons according to the dialog.

what could possibly go wrong? :D
Go to Top of Page

support
Whole Tomato Software

5566 Posts

Posted - Dec 08 2005 :  11:19:28 PM  Show Profile
Excellent description.

We can reproduce the problem.

case=920
Go to Top of Page

support
Whole Tomato Software

5566 Posts

Posted - Dec 17 2005 :  11:36:45 AM  Show Profile
Fixed in 1438.
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Topic Locked
 Printer Friendly
Jump To:
© 2019 Whole Tomato Software, LLC Go To Top Of Page
Snitz Forums 2000