Whole Tomato Software Forums
Whole Tomato Software Forums
Main Site | Profile | Register | Active Topics | Members | Search | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 Visual Assist
 Technical Support
 Underlining of syntax errors doesn't work well
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

ian horowitz
New Member

5 Posts

Posted - Feb 17 2005 :  3:49:58 PM  Show Profile  Visit ian horowitz's Homepage  Reply with Quote
I've downloaded trial version of Visual Assist X 10.1.1293.0. But I have some problems with underlining. When I wrote some lines with nonexisting variables they was underlined after a while. I changed file in the editor (from the explorer on the right). And when I came back the wrong code was not underlined any more.

I have checking of spelling errors switched on too. Underlining of spelling errors is not affected.

So, when I switch the file into source code editor back I can see underlined spelling errors, but no underlined syntax error. Underlining of code erros is just not working well.

I'm running on Windows XP, MS .net Studio 7.1.3088, .net Framework 1.1.4322.

Edited by - ian horowitz on Feb 17 2005 3:50:51 PM

support
Whole Tomato Software

5562 Posts

Posted - Feb 17 2005 :  5:27:54 PM  Show Profile  Visit support's Homepage  Reply with Quote
In what language are you programming?
Go to Top of Page

ian horowitz
New Member

5 Posts

Posted - Feb 18 2005 :  02:42:43 AM  Show Profile  Visit ian horowitz's Homepage  Reply with Quote
I tried it in C# and C++.
Go to Top of Page

ian horowitz
New Member

5 Posts

Posted - Feb 18 2005 :  1:33:07 PM  Show Profile  Visit ian horowitz's Homepage  Reply with Quote
I've installed VS .net 2003 + VAX 1293 on another computer. Same problem.
Is there a problem if there is Visual Studio 6.0 and older Visual Assist (6.?) as well ?

I got it. When I change something, the underlining will be there.
If I switch between the files after I save the file, the underlining will be gone.
Interesting.

But I can get no underlining with C# yet. Is it on purpose ?

Edited by - ian horowitz on Feb 18 2005 2:16:45 PM
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
13720 Posts

Posted - Feb 19 2005 :  6:38:16 PM  Show Profile  Reply with Quote
not underlining in files that have not been modified is an optimisation to speed things up.

like you i cannot get mistyped symbols to underline in C#. if i compile some code with a mistyped symbol i end up with a blue underline, but this is not the colour i have VAX set to use for mistyped symbols. i am guessing the IDE added this underline.

case=509

zen is the art of being at one with the two'ness
Go to Top of Page

ian horowitz
New Member

5 Posts

Posted - Feb 21 2005 :  04:24:04 AM  Show Profile  Visit ian horowitz's Homepage  Reply with Quote
It would be probably better if users can switch this "optimisation" on/off, wouldn't it ?

Am I suppose to try another version of VS .net to get underlining of mistyped symbols in C# working ?

Edited by - ian horowitz on Feb 21 2005 04:25:23 AM
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
13720 Posts

Posted - Feb 21 2005 :  5:48:00 PM  Show Profile  Reply with Quote
the optimisation was turned off for spelling errors, since it kept on confusing people.

as for C# and underlining symbols, i suspect we just have to wait for WT to fix this bug. not ideal, but at least it is now in the queue of things to be done.

zen is the art of being at one with the two'ness
Go to Top of Page

ian horowitz
New Member

5 Posts

Posted - Jan 19 2006 :  09:40:47 AM  Show Profile  Visit ian horowitz's Homepage  Reply with Quote
Lately I tried to install another version of Visual Assist X (1418) but It seems that the underlining of errors (undefined variables and methods/functions) doesn't work still. And now it didn't underline the mistakes at all.

I didn't mentioned it early that I have english version of VS .NET and czech MS Widnows XP Pro. I don't know if maybe this (czech version of XP) couldn't lead to that problems.

Do you have any advice for me ?


Go to Top of Page

feline
Whole Tomato Software

United Kingdom
13720 Posts

Posted - Jan 19 2006 :  4:23:19 PM  Show Profile  Reply with Quote
i have just checked the case, and this problem has been fixed in VA 1428, so all versions newer than this should correctly underline unknown symbols in C#

this screen shot is from a C# project in VS2005 with VA 1440. i have set VA to use the pink / purple colour for its own underlining, for clarity


zen is the art of being at one with the two'ness
Go to Top of Page

support
Whole Tomato Software

5562 Posts

Posted - Oct 29 2007 :  02:48:24 AM  Show Profile  Visit support's Homepage  Reply with Quote
case=509 is fixed in Build 1614
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
Whole Tomato Software Forums © 2014 Whole Tomato Software, Inc Go To Top Of Page
Snitz Forums 2000